$re = '/^.*(?<!\S)([^,\n]*(?:,[^,\n]*){2})$/m';
$str = 'V1, V2, V3, V4, V5, V6, V7, V8, V9, V10
V8, V9, V10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);