$re = '/\(.+\(([^()]*)\)\)*/m';
$str = '; (113 (1 2 3) )
(1 2 3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);