const regex = /^(nombre|apellido|dirección):(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(nombre|apellido|dirección):(.*)$', 'gm')
const str = `nombre:Herbert
apellido:Saal
dirección:Man cesped #50`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);