$re = '/\d+(?=(?:\w+\d)?\b)/m';
$str = 'asd78hk56gh876jkl76k8 an122fgfg5656kl56w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);