package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\d+h)?([\s]*(\d+m))?)`)
var str = `45m
1h
2h 45m
2m 45h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}