$re = '~(?<MutilineCommentNested>
/\*
[^*/]*+
(?> [^*/]++
| \*[^/]
| /[^*]
| (?&MutilineCommentNested)
)*+
\*/
)~xsX';
$str = '
ghjgh hfj
fghfg hfg
/*dfg fg ddf
/*nes*ted1*/
/**/
dfdf* /hgf ghgfh *
gd
/*nes/ted2*/
dfg*/
xcvsdgdf dfghdfg
sdfsdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);