#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).*BOURKE.*"
Local $sString = "initial text" & @CRLF & _
"preliminary text" & @CRLF & _
"unfinished line bfore the line I want" & @CRLF & _
"001 BOURKE, Bridget Mary ....... ........... 13 Mahina Road, Mahina Bay.Producrs/As 002 BOURKE. David Gerard ..." & @CRLF & _
"line after the line I want" & @CRLF & _
"extra text" & @CRLF & _
"extra extra text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")