$re = '/([0-9]+|a)([lr]?)/m';
$str = '1
a
al
l';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);