import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<g1>^.+)(?<g2>\\|)(?<g3>\\w*)";
final String string = "VERNIZ FOSCO PU 5:1|6190734832\n"
+ "VERNIZ FOSCO PU BICO|6190737676\n"
+ "VERNIZ FOSCO SAYERLACK 900ML|5482326670\n"
+ "VERNIZ MARITIMO INCOLOR - [3,6 LT]|6605544243\n"
+ "VERNIZ MARITIMO INCOLOR - [900 ML]|6605544245\n"
+ "VERNIZ PU 0491 - DUXONE|2739465076\n"
+ "VERNIZ PU 10.000 SKYLACK|5026534877\n"
+ "VERNIZ PU 6100 - LAZZURIL|2422595915\n"
+ "VERNIZ PU 8050 - LAZZURIL|2422595909\n"
+ "VERNIZ PU BRILHO 20|5109244189\n"
+ "VERNIZ PU FOSCO - LAZZURIL|2730718333\n"
+ "VERNIZ PU FOSCO - [750 ML] - SKYLACK|3551612362\n"
+ "VERNIZ PU MASCARA NEGRA|4988056487\n"
+ "VERNIZ PU SEMI-FOSCO|4717802264\n"
+ "VERNIZ PU SEMI-FOSCO - 3600 ML - FARBEN|3850897363\n"
+ "VERNIZ PU SEMI-FOSCO - 750 ML|4909315994\n"
+ "VERNIZ PU SEMI-FOSCO - 900 ML - FARBEN|3850897360\n"
+ "VERNIZ PU SEMI-FOSCO 750ML|5026534871\n"
+ "VERNIZ PU TRANSPARENTE FOSCO – 6713 - SAYERLACK|3475203973\n"
+ "VERNIZ SKYFAST HS 5:1 - SKYDUR - [900 ML]|4359364616\n"
+ "VERNIZ ULTRA 7000|2587796536\n"
+ "VESUVIO|4507424840\n"
+ "VIOLETA PU C/ CAT|6902409301\n"
+ "WASH PRIMER - [600 M|6190739255\n"
+ "WASH PRIMER - [600 ML] - BRAZILIAN|6121038554\n"
+ "WASH PRIMER VINILICO|6190737471\n"
+ "WASH/PRETO FOSCO - DX9000 - [600 ML] - BRASILUX - KIT|2422594658\n"
+ "WASH/PRETO FOSCO - DX9000 - [600 ML] - DUXONE - KIT|3147792988\n"
+ "WASH/PRETO FOSCO - [600 ML] - MAXIRUBBER|4528448069\n"
+ "WASH/PRETO FOSCO - [900 ML] - MAZA - KIT|3583355677\n"
+ "WASHPRIMER 1/4|6190735139\n"
+ "WHITE LUB - [300 ML]|4648227158\n"
+ "ZARCAO - [3,6 LT]|6605544226\n";
final String subst = "${g3}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}