using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s-]";
string input = @"91-011-23413627
21 011 23412331
91-22-5767801
91-22-5767801
31-424-2339056
91-731-2530659
92-731-2431956
1-731-2530659111
91-731-2431956
111 739 2530659111
091-011-23413627
121 011 23412331
291-322-5767801
491-22-5767801
531-424-2339056123
291-731-2530659123
192-731-2431956
122-731-2530659111
912-731-2431956{-truncated-}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}