re = /\[[^\]\[]*\]\[2\]/m
str = '[Some Text][1][Some Text][2][Some Text][3][Some Text][4]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end