$re = '/^(?=[A-Z]+)[a-z0-9A-Z-.]{5,30}(?<![-.])$/m';
$str = 'David Varghese
Johndoe-123
Janesmith@123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);