import re
regex = re.compile(r"box(?!-shadow) ")
test_str = ("positive lookahead\n"
"box(?=-shadow)\n\n"
"https://youtu.be/aIEjh0YsxWA?t=309\n"
"// select box only if what comes after it IS -shadow\n\n"
"box-sizing\n"
"shape-shadow\n"
"------------------------------------------------------------------\n"
"negative lookahead\n"
"box(?!-shadow) \n\n"
"// select box only if what comes after it IS NOT shadow\n\n"
"box-sizing\n"
"shape-shadow\n\n"
"------------------------------------------------------------------\n"
"negative look behind\n"
"(?<!jeffery).+\n\n"
"https://youtu.be/aIEjh0YsxWA?t=212\n"
"// this string cannot come before the @\n\n"
"jeffrey@envato.com\n"
"joe@envato.com\n\n"
"------------------------------------------------------------------\n"
"positive look behind\n"
"(?<=box-)sizing\n\n"
"https://youtu.be/aIEjh0YsxWA?t=337\n"
"// only want to select 'sizing' if what comes before it is 'box' \n"
"// select sizing as long as what comes before it is 'box'\n\n"
"box-sizing\n"
"shape-sizing\n\n"
"------------------------------------------------------------------\n\n"
"negative look behind\n"
"(?<!box-)sizing\n\n"
"// anything can come before it except 'box'\n\n"
"box-sizing\n"
"shape-sizing\n\n"
"-----------------------------------------------------------------\n"
"positive lookahead \n"
"@.+(?=\\.[a-z]{2,4})\n\n"
"// Matches a group after your main expression without including it in the result\n\n"
"wilson@gmail.com\n"
"frank@france.fr\n"
"joe@paris.france\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")