$re = '/^[0-5]?\d:[0-5]\d$
/m';
$str = '07:35
7:35
9:00
60:33
59:OO
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);