$re = '/(?:[^,]+\K,){8}/';
$str = '1,2,3,4,5,6,7,8,9,10,11,12,13,14,15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);