# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\w)(?!-\w)(?: ?-+ ?)+(?=\w)"
test_str = ("<!-- The following should match. Not the dashes in the comment tag, obviously ;P -->\n"
"<h2 class=\"chapter_title\">Chapter 01 -- The Beginning</h2>\n"
"<h2 class=\"chapter_title\">Chapter 02 - The Reckoning</h2>\n"
"<h2 class=\"chapter_title\">Chapter 03 - - The Aftermath</h2>\n"
"<h2 class=\"chapter_title\">Chapter 04--The Conclusion</h2>\n"
"<p>I was having the usual - cheeseburger and a cold beer.</p>\n\n"
"<!-- The following should not match -->\n"
"<p>I was wearing a t-shirt.</p>\n"
"<p>It was a drunken mix-up</p>\n"
"<p>---</p>\n"
"<p>-----</p>\n"
"<p>- - -</p>\n"
"<p> - - </p>\n"
"<p> - - - </p>\n")
subst = "—"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.