$re = '/^\s*([A-Z]+)[\t\s]+(\d+)[\s\t]+(\w+)$/m';
$str = 'I have these lines
FOO 100 BOR
PAL 350 PIL
KIL 090 KUP
array(100, "FOO", "BOR"),
array(350, "PAL", "PIL"),
array(090, "KIL", "KUP"),';
$subst = "array(\2, \"\1\", \"\3\"),";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;