import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?<email1>[^\\@]+\\@[^\\@]+)\\]\\s+\\[.*emailAddress\\\":\\\"(?<email2>[^\\\"]+)";
final String string = "[INFO ] 2020-11-16 20:52:30,729 (http-nio-8085-exec-127) [MyServiceImpl(emailServ:6431)] [my email@yahoo.com] [4223TD-E3DE-2345-8E59-1-YDHGC] Validation failed.Invalid. Response JSON {\"emailAddress\":\"mynewemail\",\"statusReason\":\"failed_syntax_check\",\"domain\":\"\",\"processedAt\":\"2020-11-16 20:52:30 GMT-0700 (MST)\",\"cache\":false,\"account\":\"\",\"status\":\"invalid\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}