using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(?:\(|\[)";
string input = @"some text (part1)
even some text (part1)
some text / ... (part1) (part2)
(part1)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}