import Foundation
let pattern = #"(?P<first>^(?P<intend>\s*?)diagGetParameterRaw.+?(?P<diagresp>\w.+?),.*?\"SecurityClass\", (?P<first_rest>.+?;(?P<newline>[\n\r]+)))(?P<second>(?P<second_start>\s*?_DiagGenerateKeyFromSeed.+.?buffer,).+?(?P<second_rest>0x\d+?,.+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
// diagGetParameterRaw(transition_1_2_0_Resp, "SecurityClass", buffer, 4096);
// _DiagGenerateKeyFromSeed (buffer, 1, 0x11, "BR120x", "", op1, 6, _length); length = 6;
*******
diagGetParameterRaw(transition_1_2_0_Resp, "SecurityClass", buffer, 4096);
_DiagGenerateKeyFromSeed (buffer, 1, 0x11, "BR120x", "", op1, 6, _length); length = 6;
diagGetParameterRaw(transition_1_2_0_Resp, "SecurityClass", buffer, 4096);
_DiagGenerateKeyFromSeed (buffer, 1, 0x11, "BR120x", "", op1, 6, _length); length = 6;
****************
RawDiagGetParameterRaw(transition_1_0_0_Resp, 16, 64, buffer, 4096);
_DiagGenerateKeyFromSeed (buffer, 8, 0x11, "BR120x", "", op1, 6, _length); length = 6;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<newline>\g<intend>\g<newline>//\g<intend>removed the next two lines as diva uses only one of our three parameters\g<newline>//\g<first>//\g<second>\g<newline>//\g<intend>\g<newline>//\g<intend>this works correctly:\g<newline>\g<intend>\g<newline>\g<intend>RawDiagGetParameterRaw ( \g<diagresp>, 16, 64, \g<first_rest>\g<second_start> 8, \g<second_rest>\g<newline>\g<newline>//\g<intend>replacement ends here\g<newline>\g<intend>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)