$re = '/foo(?!.*\n.*bar)/m';
$str = '1 foo 1
foo 2
baz bar bap
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);