import Foundation
let pattern = #""Key":"X-Real-IP",\s*"Value":\[\s*"(?<X_Real_IP>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"Request":{
"Uri":"/api/...",
"requestHeaders":[
{
"Key":"X-Real-IP",
"Value":[
"213.205.240.26, 55.145.164.26"
]
},
{
"Key":"X-Forwarded-For",
"Value":[
"111.111.240.26"
]
},
"ContentHeaders":[
{
"Key":"Content-Length",
"Value":[
"0"
]
}
],
"Body":null
},
"Response":{ },
"TimeTakenMs":119
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)