$re = '/\{[0-9]*\:[0-9]*\}/';
$str = '{1:69}
{1:2}
{1:3,2:1}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);