$re = '/(^|[^\d.\n])\b\d+\b(?!\.\d)/m';
$str = '= INT
123
+333
-5
= FLOAT
1334.455
.323
-323.323
+.2
-.34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);