package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[&?]list=([^&\n]*)`)
var str = `&list=fifteen&more=here
&list=fifteen`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}