$re = '/(?:\[#\d+\K,|(?<!^)\G,)(#\d+)/';
$str = '#2335, IFCRELASSOCIATESMATERIAL, \'2ON6$yXXD1GAAH8whbdZmc\', #5,$,$, [#40,#221,#268,#281],#2334';
$subst = "_$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;