re = /.*(\[.*\])/
str = 'data[X][XX][XXX]
asdfasdfasdf[]asdfadsf[]asdfasdf[ddd]sdfsdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end