re = /\bdo\b|\be\b|\bo\b/mi
str = 'Brasil, oficialmente República Federativa do Brasil é o maior país da América do Sul e da região da América Latina, sendo o quinto maior do mundo em área territorial (equivalente a 47% do território sul-americano) e sexto em população (com mais de 200 milhões de habitantes). É o único país na América onde se fala majoritariamente a língua portuguesa e o maior país lusófono do planeta, além de ser uma das nações mais multiculturais e etnicamente diversas, em decorrência da forte imigração oriunda de variados locais do mundo. A sua Constituição atual, formulada em 1988, define o Brasil como uma república federativa presidencialista, formada pela união do Distrito Federal, dos 26 estados e dos 5 570 municípios.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result