package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\x00-\xff])+`)
var str = `我们,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}