$re = '/^\d{1,2}(\.\d{1,14})?$/m';
$str = '1
12
0
99
1.0
11.0
99.0
99.99999999999999
123
100
123.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);