$re = '/.*a.*a.*a.*/m';
$str = 'abracadabra
abraham
apple
alan
alaska
rhaegaar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);