$re = '/^ActiveMods=(?<ModID>[,\s\d]+) , (?<CustModID>[,\s\d]+)$/m';
$str = 'ActiveMods=111111111, 222222222 , 333333333, 444444444
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);