use strict;
my $str = ' this is in blue color","(Refer: \'(color:rgb(61, 142, 185); )Set the TEST VIN value\'(color:rgb(0, 0, 0); ) in document: (color:rgb(61, 142, 185); )[UserGuide_Upgrade_2020_W10_final.pdf|CB:/displayDocument/UserGuide_Upgrade_2020_W10_final.pdf?task_id=12639618&artifact_id=48569866] )';
my $regex = qr/\(color:\w+\([^()]*\); \)|\?[^?]+(?=\)$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";