package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<name>\w+\s\w{1,2})`)
var str = `John P Maria Do Fred T`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}