re = /(?:https?:\/\/)?(?:www.)?instagram.com\/?([a-zA-Z0-9\.\_\-]+)?\/([p]+)?([reel]+)?([tv]+)?([stories]+)?\/([a-zA-Z0-9\-\_\.]+)\/?([0-9]+)?/m
str = '// Group 2
https://www.instagram.com/p/CKYJRXVnwMO/?utm_source=ig_web_copy_link
instagram.com/p/CKYJRXVnwMO
www.instagram.com/p/CKYJRXVnwMO
https://www.instagram.com/taiga765/p/CYS-O2Gr8xZ/?utm_medium=copy_link
https://www.instagram.com/y.uuno/p/CXR5ATPls5M/?utm_medium=copy_link
// Group 3
http://www.instagram.com/reel/CRftq6QgG89/?utm_source=ig_web_copy_link
instagram.com/reel/CRftq6QgG89/
www.instagram.com/reel/CRftq6QgG89/
https://www.instagram.com/reel/CXR2xvbgCKW/?utm_medium=copy_link
// Group 4
https://www.instagram.com/tv/CN4RZWGn5wS/?utm_source=ig_web_copy_link
instagram.com/tv/CN4RZWGn5wS/
www.instagram.com/tv/CN4RZWGn5wS/
// Group 5
https://www.instagram.com/stories/sintha_tatha/2725190842360050880/
https://www.instagram.com/stories/urkawaiibae/2725982322342818754/
https://www.instagram.com/stories/willypangestu_/2725773180739197900/
https://www.instagram.com/stories/atrisna477769/
https://www.instagram.com/stories/highlights/17910460144693951/
www.instagram.com/stories/highlights/17879710684406193/
instagram.com/stories/highlights/17879710684406193/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end