$re = '/(.)(?=(.\1))/m';
$str = 'b9fgh9f1;2w;111b2b35hw3w3ww55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);