import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)дополнительн\\w*\\sлицензи(?!он)|(лицензи(?!он)\\w*\\W*\\sдополнительн\\w*\\s)";
final String string = "когда срок действия активной лицензии истекает, активируется дополнительная лицензия\n"
+ "лицензия дополнительная \n"
+ "дополнительная и активная лицензии\n"
+ "лицензия является дополнительной, если\n"
+ "лицензия, дополнительная и\n"
+ "лицензия, активная и дополнительная";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}