$re = '/(?<=FROM:\s).*?([\n])/m';
$str = 'FROM: James Bond
Associate Director, C Team
Office of Towers
SUBJECT: XYZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);