package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*([^#][\w\d_-]+?)\s*=\s*(\d+)\s*$`)
var str = `; This is a sample configuration file
; Comments start with ';', as in php.ini
[first_section]
one = 1
one = 3
one-two = 4
one_three = 3
five = 5.2
animal = BIRD
[first_section]
second_section[one] = "1 associated"
second_section[two] = "2 associated"
second_section[] = "1 unassociated"
second_section[] = "2 unassociated"
second_section[] = 1
second_section[] = 1,3
second_section[] = 2,2
[second_section]
path = "/usr/local/bin"
URL = "http://www.example.com/~username"
second_section[one] = "1 associated"
second_section[two] = "2 associated"
second_section[three] = 3
second_section[four] = 4.4
second_section[] = "1 unassociated"
second_section[] = "2 unassociated"
second_section[] = 1
second_section[] = 2.2
[third_section]
phpversion[] = "5.0"
phpversion[] = "5.1"
phpversion[] = "5.2"
phpversion[] = "5.3"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}