re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\^$*.\[\]{}\(\)?\-\"!@#%&\/,><\':;|_~`])\S{8,99}$/
str = 'abcASD123333"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end