import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^201[4-9]|202[0-9]$";
final String string = "2015\n"
+ "2024\n"
+ "1994\n"
+ "2014-03\n"
+ "2013\n"
+ "2019\n"
+ "2012-04\n"
+ "2019-05";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}