re = /(?:{[^{}]*}|[^,])+/x
str = '65101km,Sedan,Manual,18131A,FWD,Used,5.5L/100km,Toyota,camry,SE,{AC,Heated Seats, Heated Mirrors, Keyless Entry},2010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end