$re = '/EXTINF:(\d+\.\d+),\r?\n(.*)/';
$str = '#EXTM3U
#EXT-X-VERSION:3
#EXT-X-MEDIA-SEQUENCE:153741
#EXT-X-ALLOW-CACHE:NO
#EXT-X-TARGETDURATION:11
#EXTINF:10.005333,
/RTS_1_009/audio/2018-03-16-H13/audio-2018-03-16-13-58-29.ts
#EXTINF:9.984000,
/RTS_1_009/audio/2018-03-16-H13/audio-2018-03-16-13-58-39.ts
#EXTINF:10.005333,
/RTS_1_009/audio/2018-03-16-H13/audio-2018-03-16-13-58-49.ts
#EXTINF:10.005333,
/RTS_1_009/audio/2018-03-16-H13/audio-2018-03-16-13-58-59.ts
#EXTINF:10.005333,
/RTS_1_009/audio/2018-03-16-H13/audio-2018-03-16-13-59-09.ts
#EXTINF:9.984000,
/RTS_1_009/audio/2018-03-16-H13/audio-2018-03-16-13-59-19.ts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);