re = /(?:\K [^ ]*)+/m
str = 'Buddy you\'re a boy make a big noise Playin in the stre'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end