$re = '/(\'.*?\')*/m';
$str = 'aaa\'bbb"ccc"ddd"d\'dsds\'"aaaa\'djhfadkjfh\'aslkdfjlasdkfj\'sdfasdfsdf" sdlkfl;sdkf;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);