re = /^(.*[\\\/])article[0-9]{6,}.*/m
str = 'https://www.welt.de/food/essen/article206809645/Kekse-backen-ohne-Mehl-Schoko-Cookies-mit-Meersalz.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end