re = /^(?:[\w]\:|\/)(\/[a-z_\-\s0-9\.]+)+\.(txt|gif|pdf|doc|docx|xls|xlsx|js)$/i
str = 'c:/pippo/pluto/paperino/zio.paperone.js'
# Print the match result
str.match(re) do |match|
puts match.to_s
end