# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*\{\\/\*DELETE}(\s*(?:\r?\n(?!\s*\{(?:\\/\*DELETE|DELETE\*\\/)}).*)*)\r?\n\s*\{DELETE\*\\/}\s*$//gm;t' <<< "Keep1
{/*DELETE}
Delete1a
Delete1b
{DELETE*/}
Keep2
Keep3"