$re = '/^{([A-Za-z0-9 ]+)}|[^\\\\\r\n]{([A-Za-z0-9 ]+)}/m';
$str = '{it} works with with words.
{0} works with digits.
{it} works with whitespace.
{ {it} } doesn\'t work on outer nestings.
\\{it} should be escaped.
Hello, {name}! {name}, \\{escaped} are {0} years old!.
Hello, {name}!\\nJS Object = {name: {name}, age: {age}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);