$re = '/.*Source[\\\\\/]([^\\\\\/]+)[\\\\\/](?:Private|Public).*/m';
$str = 'd:\\dev\\Pseudope\\Unreal\\Cubicle\\Source\\CubicleCore\\Private\\';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;